Categor铆as
WordPress

Puedes probar la traducci贸n de WP 3.9

He escrito en Mecus c贸mo hacerlo.

Categor铆as
Mecus WordPress

Beta testing WordPress

Hace unos d铆as os cont谩bamos que WordPress est谩 necesitado de usuarios que quieran participar en el beta-testing de las versiones de desarrollo. La preocupaci贸n de que haya m谩s gente probando el sistema para poder localizar los posibles fallos lo antes posible no es s贸lo nuestra. Ryan Boren, uno de los desarrolladores principales de WordPress, tambi茅n ha escrito sobre ello y hace un peque帽o tutorial para que, si somos un poco intr茅pidos, seamos capaces de cambiar nuestra versi贸n de WordPress por las versiones de desarrollo. Y, si no est谩is muy familiarizados con el ingl茅s, Fernando Tellado nos cuenta c贸mo hacerlo en espa帽ol.

Pero si alguna vez te pic贸 la curiosidad de ser beta tester pero te sigue pareciendo muy complicado, Peter Westwood (westi), uno de los Lead Developer de WordPress, nos ha preparado una soluci贸n:

Westi se ha planteado que uno de los grandes problemas que tiene ahora mismo con el tema del beta-testing es que tiene que cambiar las versiones que est谩 utilizando a mano cada vez que haya una actualizaci贸n. Para hacerlo m谩s sencillo (y, sobre todo, para que no tengamos que tocar archivos fuera del directorio wp-content 鈥搑ecordemos que el archivo versions.php est谩 en el directorio wp-includes鈥), ha creado un plugin que nos permitir谩 ser beta-testers s贸lo con instal谩rnoslo.

WordPress Beta Tester Admin
WordPress Beta Tester Admin

Con el plugin podremos elegir dos sabores:

  • Point release nightlies. Actualizar谩 los archivos del trac que est茅n marcados como pr贸xima versi贸n menor. Para WordPress 2.8, la pr贸xima versi贸n menor ser铆a la 2.8.1.
  • Bleeding edge nightlies. Actualizar谩 todo lo que se haya tocado hasta el momento. Esta opci贸n es la de desarrollo propiamente dicho, y puede ser inestable (es decir, puede que haya cosas que no funcionen porque aparezca alg煤n bug). As铆 que si te apuntas a este sabor, estate preparado para lo que te espera :).

Con cada versi贸n mayor de WordPress (2.8, 2.9, 3.0…) se suele cambiar, por optimizaci贸n, la estructura de la base de datos. Este plugin tambi茅n nos actualizar谩 la versi贸n correspondiente de la base de datos (el schema) que debemos usar.

Una vez que est茅s utilizando una versi贸n mayor, no podr谩s dar marcha atr谩s, ya que no tenemos ninguna herramienta para modificar la base de datos a la versi贸n anterior. Tenlo en cuenta antes de utilizar la bleeding-edge.

Descargar WordPress Beta Tester.

We want you to test WordPress